Integration Pack for PowerShell Script Execution

Rating:        Based on 1 rating
Reviewed:  1 review
Downloads: 1616
Released: May 4, 2011
Updated: May 4, 2011 by charlesjoy
Dev status: Stable Help Icon

Recommended Download

Application Integration Pack for PowerShell Script Execution 1.00
application, 847K, uploaded May 4, 2011 - 935 downloads

Other Available Downloads

Documentation Integration Pack for PowerShell Script Execution 1.0 - User Guide
documentation, 477K, uploaded May 4, 2011 - 681 downloads

Release Notes

The Integration Pack for PowerShell Script Execution

This IP provides extended PowerShell Script Execution capabilities to OIS (executed from and against both x86 and x64 OSs).

This Integration Pack adds the following objects to Opalis Integration Server:

• Execute PS Script
• Execute PS Script - Global

System Requirements

• System Center Opalis Integration Server 6.22 or greater
• System Center Opalis Quick Integration Kit 3.0 or greater (library included)
• Microsoft .NET 2.0 Framework (required for Quick Integration Kit)
• PowerShell 2.0
winrm quickconfig command executed on local and target machines where PS Scripts will be executed

Please Refer to the included User Guide as well as the available TechNet Blog Post (http://blogs.technet.com/b/charlesjoy/archive/2011/05/04/ois-integration-pack-for-powershell-script-execution-1-00.aspx) for more information.

Reviews for this release

     
This one has saved my bacon. Besides making it easier to use PS code in workflows, the fact that it allows for your choice of security configuration is invaluable. Some operations need to use privledges that I do not want to grant the Opalis service. Hard coding the user and password into the script is not acceptable. Creating a QIK each time is not practical. This IP solves that problem.
by carmencr on May 23, 2011 at 8:48 PM